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Got a video or model you want to analyze? Awesome! Here’s how to get data from it.
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Tracking Points from a Movie in Tracker

1) Download Tracker: https://physlets.org/tracker/

2) Open the video in Tracker

3) You can select a specific starting point for the video using the small black triangle under the
time bar. | would suggest starting somewhere in the middle where there are few frame
breaks, glares, bubbles, etc. You can choose an ending point the same way.

4) Set coordinate axes for your points to be based off (the icon with the two intersecting pink
lines). | like to set the axes for the center and top of the glacier, but you can choose what
makes the most sense for representing your data.

@ Tracker
File Edit Video Track Coordinate System View Help

9 m*\l"' ¥create == B | Q43w | 0y | N O A A |4 A | A A
—+axes [Jorid v origin pixel [Siow or hide the coorainate aves || angle from horizontal[0.0° ]
S '
4

[z=0E0_y=0EQ] elected (set angle to change tilt
061 |100% B M P» F .\ ,{;‘j \ — } —
1 11_10 Test 5fps.mp4 | N J

5) Choose what points you want to auto-track. | would suggest all the top row and several from
the bottom of the frame as well to get a robust dataset from all along the glacier. To create
these tracks:

a) Create > Point Mass, then a box should come up with an icon labeled mass A. | would
rename this so you have an idea of what/where all your points are. Right click on the
mass A label to rename. Here I've labeled it topleft1.
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b) There are two kinds of tracking you can do, manual tracking and autotracking. The
difference between these two in terms of selection is all in your keyboard controls. Note:


https://physlets.org/tracker/

| used this program in Windows, the keyboard controls may be different for Mac or
Linux.

)

Manual tracking: Hold down the shift key as you select a point on the video. Your
mouse cursor should turn into a square to highlight the dot you want to measure
throughout the video. With manual tracking, you can select a first point in time, then
skip ahead multiple frames to get another position for that same point.
Autotracking: This will generate a large dataset for any points you want and the
program does the heavy lifting. Hold down control and shift as you select a
starting point on the video. Your mouse cursor should be a circle now. The
autotracker toolbox will automatically pop up with the “template” of the image you
selected with your cursor and whether it can find another match or not. On the video,
you can see the point outlined by a red dotted box labeled “0” meaning it is the first
frame. As you go through the video, each new coordinate pair will be labeled with a
consecutive number. If you are satisfied with the starting point you chose, then click
the “Search” button and it will track that point through the portion of the video you
originally selected.
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If there are ever any frames where it can’t find a match, an error message will pop up
in the text part of the Autotracker toolbox asking you whether you would like to
accept the match or skip it. Usually, if it gets confused it will be trying to select a point
that is on the other side of the video, so | skip it and just make sure to look at that
time signal when | am calculating velocities later. You can also manually choose a
point for that frame if you want to keep that frame in the dataset.

If you are satisfied with your results, you can exit the autotracker toolbox.

6) To the right of your screen you now have two forms of data: your graph and your table. The
table has the raw data which you will want to save to an Excel file for analysis in Surfer if
that is your route.

a) Saving Data: File > Export > Data File... > Save As. Make sure you change “cells” from
“selected cells” to “all cells” otherwise you will probably only get one data point. This will
give you positions and times of a track.

b) In Excel, you can combine multiple tracks together to get more data points and divide
the change in distance by the change in time between two points to get velocity.
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7) With the graph, you can expand it by clicking on the triangle in the right corner. In the graph,
you can change either axis by clicking on their labels. The default is position versus time,

but the software gives you many options to choose from (like velocity and acceleration) and
even lets you create your own.
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8) Make sure you repeat steps 5 and 6 for more data points so you can get velocity across the

whole glacier.

© pixely. pixel y-component

Getting Strain Rates in Surfer 13

1) Use tracker to put an excel file together of the initial positions and velocities

2) Gridding Data
a) Grid > Data...
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3)

b)

d)

f)

9)

h)

Select the file you are using (your Tracker Excel file), then a box will pop up where you
will describe what your grid file will look like.

Grid Data - C\Users\Geodynamics\Docurnents\Kate\Model Glacier\Ne... 7 >
Data Columns (108 data points)
X: |Column C: x {across) ~ Filter Data...
Cancel
i | Column D: y {down) ~ View Data =
Z: | Column H: u v Statistics [ Grid Report
Gridding Method
Kriging ~ || Advanced Options... Cross Validate. ..

Grid Line Geometry

Minimum Maximum Spadin # of Nodes
X Direction: | -130.0615594 158.2440481 11.088568106 27

¥ Direction: | -1091.391402 | [3.119573888 | [11.05566743 | [ 100

Grid 7 Limits

i m Z Transform: | Linear ~
Minimum: | Mone ~

[ Blank grid outside convex hull of data
Maximum: | Mone i 0

Output Grid File
C:\Users\Geodynamics\Documents \Kate Model Glacier \New Vids\DryBase \All 3Tracks_ |2

In the Data Columns spot, make sure the x and y pull-down menus match what you want
on the two axes. Note: If you are using a glacial coordinate system, it can be a little
counterintuitive if we are talking about a glacier flowing from the top of the image to the
bottom of the image (“x” glacier flow is actually the y axis and “y” flow is actually the x
axis).

Choose Kriging for the Gridding Method

Set the Grid Line Geometry to a little outside your farthest points

# of nodes and spacing depends on how many data points you have. If you only have 5
data points, but select 50 nodes then your generated map will have a fine resolution but
all the points in between will just be extrapolated by the program, not actual data (similar
to accuracy versus precision).

Make sure to specify the output file name and location so you don’t accidentally write
over any previous grids.

Do this for all your velocities (X, y, z). Make sure they all have the same Grid Line
Geometry and spacing/nodes or you will not be able to compare the files. | usually
screenshot the first Grid Data box before | click ok so | have all the number | input and
can use those same number for the next grids.

Creating Contour Maps

a)

Map>new>contour map=>select any of your velocity grids
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b) It comes out looking like this
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¢) To make it more than just a bunch of lines in a rectangle:
i) Inyour object manager panel (left side), click on the contour map name so it's
highlighted. Below the object manager there is the property manager panel, this is
where you can change properties of the map.

i) For color: Property manager>Levels>Filled Contours. Check
the fill contours box. Then you can click on the box that
shows the grayscale to change the color scheme you want.
If you click on the “...” to the right of that you can change
the bounds on the colors (making 0 white, changing the
maximum and minimum to set multiple maps to the same
scale, etc).

i) If you just want colors, and don’t want contour lines or
labels, go to Major Contours and Minor Contours right below
Filled Contours. You can uncheck the Show Labels box to
get rid of the numbers on your contours. You can also click
on the line to bring up a pull-down menu that allows you to
change the line type.




iv) You can also change the size of the map while still scaling
everything accurately (if you just drag the corner to make it
bigger it warps the lettering and numbers on your axes or
contour lines). In Object Manager, click on Map so it's

=== I highlighted then in the Property Manager click the Scale tab.
Here you can change the X Scale and Y scale length. If you
don’t want it to change one when you change the other,
uncheck the Proportional XY scaling box.

v) To add text, Draw>Text

(1) The text doesn’t always change
size when you manipulate it in
the box that comes up where
you are typing the text. My tip is
to write the text and then
manipulate it with the Property
Manager panel.

vi) In the Draw tab you can also add
squares for borders, shapes for
legends, etc.

vii) If you are layering maps and have axes that are in different units or the labels are
getting thick, you can uncheck the Right/Left/Top/Bottom Axis boxes in the Object
Manager to keep the initial contour (or other) image but not the axes.

4) Creating Vector Maps
a) Map>New>2-Grid-Vector-Map...

I@ Surfer - [Plot1*]
@) File Edt View Draw Amange Grid | Map | Geoprocessing Tools Window Help
i ime F e G %0 S New »|[Eg Base Map from Server... \ 4
X 21864778 2 ¥ 11760103 1 W e ¥|[E] Base pap. TET
Object Manager il Measure [ Empty Base Map...
ERE 0000000 i it &) contour tap...  —
[ | Right Axis & raan 2] Post Map...
cR L LeftAs [ Classed Post Map...

Top duis 7| Stack Maps
+[¥] . Bottom Auis Overlay Maps
~[7] [ Contours-u.grd 2\ Break Apart Layer

Edit Post Labels.

Image Map.

|74 Shaded Relief Map...
|| 1-Grid Vector Map...
(%) 2-Grid Vector Map...
Watershed Map...

Edit Contol

4 Export Contours...
Open Attribute Table... {5 3D Wireframe...

Query Objects... 4> 3D surface...




5)

6)

7

b)
c)

Select your x velocity and your y velocity grids

You will get a map with a bunch of arrows on it. If there are too many arrows to really
see what is going on, you can change the frequency of the arrows. Click on the vector
map label in the Object Manager and click on the Symbol tab. Under Symbol Properties
you can increase the X frequency and the Y frequency. Counterintuitively, the higher the
frequency the less arrows will be displayed on your map.

Scale Bars: For any of these maps, if you want a scale bar or reference vectors, you must
check the “Color Scale” box in the Filled Contours Section for Contour Maps, or the “Show
Scale Legend” in Scaling>General for Vector Maps.

Post Maps: To superimpose points on top of a contour map (for example GPS points on a
velocity contour map) go to Map>New>Post Map and select the (X, y) coordinates you want
displayed. In the Property Manager you can change how the icons for the points look.

Strain Rates

a)

b)

c)
d)

Grid>Calculus> select the file you want to take the derivative of like your velocity grids.
First select one then you will have to repeat this process again for the next.

In Surfer, the direction determines what value you are taking the velocity derivatives with
respect to. To take a derivative in the x direction (i.e. du/dx) the direction angle should
be set to 0. If you are taking a derivative in the y direction (i.e du/dy) the angle should be
set to 90.

—I- Directional Derivative oK
i First Derivative
- Second Derivative Cancel
‘... Curvature

+ Temain Modeling
+- Differential & Integral Operator
+- Fourier & Spectral Analysis
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Make sure to specify the output file name and location.
For strain rates you will have 4 grid calculus files: du/dx, du/dy, dv/dx, dv/dy
i) Principles: du/dx, dv/dy

1 du dv

Dilation = = (% 4 4V
ilation > (dx + &

i) Shears: du/dy, dv/dx
du

dv
Shear Strain Rate = (a + E



o 1 dv du
Vorticity = E(a_a

e) Once you have these files, type in the equation you want with those files.
i) Grid>Math

Grid Math ? b4
Input Grid Variable Blank Handing ~ Remap Value Add Grids...
C\Users\Geodynamics Documents'\ Kate'\M... A Blank output :
b C\Users\Geodynamics \Documents'\Kate'\M... | B Blank output 0

Enter a function of the form f{A, B, ...) where A, B, ... are the variables in the list above.
| 0.5%(A +B) v|

:
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|O =3 Cancel

Qutput Grid File:
| out.grd

i) Input the grids you are using
ii) Inthe function box, type: (A+B), 0.5*(A-B), etc.
iv) Specify the output file name and location then click ok!

f)  New>Contour Map>select the name of the math grid file you just created. The contour
map will start out looking like your velocity contour map did, but you can manipulate it in
the same way to give it color, change the size, etc. Now you should have a nice image of
your strain rates!
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